using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^$|^(?!00:00$)(([01][0-9])|(2[0-3])):[0-5][0-9]$";
string input = @"00:00
00:01
00:10
00:11
00:50
01:00
08:30
23:00
23:30
23:59
24:00
24:30";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}