import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^$|^(?!00:00$)(([01][0-9])|(2[0-3])):[0-5][0-9]$";
final String string = "00:00\n"
+ "00:01\n"
+ "00:10\n"
+ "00:11\n"
+ "00:50\n"
+ "01:00\n"
+ "08:30\n"
+ "23:00\n"
+ "23:30\n"
+ "23:59\n"
+ "24:00\n"
+ "24:30";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}