use strict;
my $str = '00:00
00:01
00:10
00:11
00:50
01:00
08:30
23:00
23:30
23:59
24:00
24:30';
my $regex = qr/^$|^(?!00:00$)(([01][0-9])|(2[0-3])):[0-5][0-9]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}