$re = '/^$|^(?!00:00$)(([01][0-9])|(2[0-3])):[0-5][0-9]$/m';
$str = '00:00
00:01
00:10
00:11
00:50
01:00
08:30
23:00
23:30
23:59
24:00
24:30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);