import re
regex = re.compile(r"^$|^(?!00:00$)(([01][0-9])|(2[0-3])):[0-5][0-9]$", flags=re.MULTILINE)
test_str = ("00:00\n"
"00:01\n"
"00:10\n"
"00:11\n"
"00:50\n"
"01:00\n"
"08:30\n"
"23:00\n"
"23:30\n"
"23:59\n"
"24:00\n"
"24:30")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")