#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-\$\d{1,3}(?:,\d{3})*$"
Local $sString = "-$1,200" & @CRLF & _
"-$750" & @CRLF & _
"-$10,000,000,000" & @CRLF & _
"-$100,000," & @CRLF & _
"" & @CRLF & _
"-$1,2" & @CRLF & _
"-$,000" & @CRLF & _
"-$1200" & @CRLF & _
"$1,200" & @CRLF & _
"$750"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")