re = /^-\$\d{1,3}(?:,\d{3})*$/m
str = '-$1,200
-$750
-$10,000,000,000
-$100,000,
-$1,2
-$,000
-$1200
$1,200
$750'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end