import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-\\$\\d{1,3}(?:,\\d{3})*$";
final String string = "-$1,200\n"
+ "-$750\n"
+ "-$10,000,000,000\n"
+ "-$100,000,\n\n"
+ "-$1,2\n"
+ "-$,000\n"
+ "-$1200\n"
+ "$1,200\n"
+ "$750";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}