// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-\$\d{1,3}(?:,\d{3})*$").unwrap();
let string = "-$1,200
-$750
-$10,000,000,000
-$100,000,
-$1,2
-$,000
-$1200
$1,200
$750";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}