import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\)\\s\\().+(?=\\s\\/)";
final String string = "1)Video: h264 (High) (avc1 / 0x31637661), yuv420p, 452x360 [SAR 1:1 DAR 113:90], 297 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc (default)\n\n"
+ "2)Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 76 kb/s (default)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}