const regex = /(?<=\)\s\().+(?=\s\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\)\\s\\().+(?=\\s\\\/)', 'gm')
const str = `1)Video: h264 (High) (avc1 / 0x31637661), yuv420p, 452x360 [SAR 1:1 DAR 113:90], 297 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc (default)
2)Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 76 kb/s (default)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}