import re
regex = re.compile(r"(?<=\)\s\().+(?=\s\/)", flags=re.MULTILINE)
test_str = ("1)Video: h264 (High) (avc1 / 0x31637661), yuv420p, 452x360 [SAR 1:1 DAR 113:90], 297 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc (default)\n\n"
"2)Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 76 kb/s (default)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")