#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*|"(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])*")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])$"
Local $sString = "abcd1090@ihavenoidea.what.going.wrong.here" & @CRLF & _
"abcd1090ihavenoidea.what.going.wrong.here@" & @CRLF & _
"abcd1090@ihavenoidea.what.going.wrong.here." & @CRLF & _
"@abcd1090ihavenoidea.what.going.wrong.here" & @CRLF & _
".abcd1090ihavenoidea.what.going.wrong.here" & @CRLF & _
"abcd1090ihavenoidea.what.@going.wrong.here" & @CRLF & _
"abcd1090ihavenoidea.what@.going.wrong.here" & @CRLF & _
"abcd1090ihavenoidea.what.going.wrong.here" & @CRLF & _
"abcd1090@ihavenoidea.what.going.wrong..here" & @CRLF & _
"abcd1090@ihavenoidea.what.going.wrong...here" & @CRLF & _
"abcd1090@ihavenoidea.what.going.wrong@@here" & @CRLF & _
"nowordwithnospace" & @CRLF & _
"john.smith@email.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")