using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*|""(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])*"")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])$";
string input = @"abcd1090@ihavenoidea.what.going.wrong.here
abcd1090ihavenoidea.what.going.wrong.here@
abcd1090@ihavenoidea.what.going.wrong.here.
@abcd1090ihavenoidea.what.going.wrong.here
.abcd1090ihavenoidea.what.going.wrong.here
abcd1090ihavenoidea.what.@going.wrong.here
abcd1090ihavenoidea.what@.going.wrong.here
abcd1090ihavenoidea.what.going.wrong.here
abcd1090@ihavenoidea.what.going.wrong..here
abcd1090@ihavenoidea.what.going.wrong...here
abcd1090@ihavenoidea.what.going.wrong@@here
nowordwithnospace
john.smith@email.com
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}