const regex = new RegExp('^(?:[a-z0-9!#$%&\\'*+/=?^_`{|}~-]+(?:\\.[a-z0-9!#$%&\\'*+/=?^_`{|}~-]+)*|"(?:[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x21\\x23-\\x5b\\x5d-\\x7f]|\\\\[\\x01-\\x09\\x0b\\x0c\\x0e-\\x7f])*")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x21-\\x5a\\x53-\\x7f]|\\\\[\\x01-\\x09\\x0b\\x0c\\x0e-\\x7f])+)\\])$', 'gmi')
const str = `abcd1090@ihavenoidea.what.going.wrong.here
abcd1090ihavenoidea.what.going.wrong.here@
abcd1090@ihavenoidea.what.going.wrong.here.
@abcd1090ihavenoidea.what.going.wrong.here
.abcd1090ihavenoidea.what.going.wrong.here
abcd1090ihavenoidea.what.@going.wrong.here
abcd1090ihavenoidea.what@.going.wrong.here
abcd1090ihavenoidea.what.going.wrong.here
abcd1090@ihavenoidea.what.going.wrong..here
abcd1090@ihavenoidea.what.going.wrong...here
abcd1090@ihavenoidea.what.going.wrong@@here
nowordwithnospace
john.smith@email.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}