use strict;
my $str = 'abcd1090@ihavenoidea.what.going.wrong.here
abcd1090ihavenoidea.what.going.wrong.here@
abcd1090@ihavenoidea.what.going.wrong.here.
@abcd1090ihavenoidea.what.going.wrong.here
.abcd1090ihavenoidea.what.going.wrong.here
abcd1090ihavenoidea.what.@going.wrong.here
abcd1090ihavenoidea.what@.going.wrong.here
abcd1090ihavenoidea.what.going.wrong.here
abcd1090@ihavenoidea.what.going.wrong..here
abcd1090@ihavenoidea.what.going.wrong...here
abcd1090@ihavenoidea.what.going.wrong@@here
nowordwithnospace
john.smith@email.com
';
my $regex = qr/^(?:[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*|"(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])*")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}