#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]"
Local $sString = "[color=red;font-size:100pt;]DEFACED[/color]" & @CRLF & _
"[color=#FF0000]DEFACED?[/color]"
Local $sSubst = "<span style="font-color:$1>$2</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)