const regex = /\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[color=(#[0-9A-F]{3,6})\\](.*?)\\[\\\/color\\]', 'gm')
const str = `[color=red;font-size:100pt;]DEFACED[/color]
[color=#FF0000]DEFACED?[/color]`;
const subst = `<span style="font-color:$1>$2</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);