using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]";
string substitution = @"<span style=""font-color:$1>$2</span>";
string input = @"[color=red;font-size:100pt;]DEFACED[/color]
[color=#FF0000]DEFACED?[/color]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}