use strict;
my $str = '[color=red;font-size:100pt;]DEFACED[/color]
[color=#FF0000]DEFACED?[/color]';
my $regex = qr/\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]/mp;
my $subst = '<span style="font-color:$1>$2</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";