$re = '/\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]/m';
$str = '[color=red;font-size:100pt;]DEFACED[/color]
[color=#FF0000]DEFACED?[/color]';
$subst = "<span style=\"font-color:$1>$2</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;