package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]`)
var str = `[color=red;font-size:100pt;]DEFACED[/color]
[color=#FF0000]DEFACED?[/color]`
var substitution = "<span style="font-color:$1>$2</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}