import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[color=(#[0-9A-F]{3,6})\\](.*?)\\[\\/color\\]";
final String string = "[color=red;font-size:100pt;]DEFACED[/color]\n"
+ "[color=#FF0000]DEFACED?[/color]";
final String subst = "<span style=\"font-color:$1>$2</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}