import re
regex = re.compile(r"\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]", flags=re.MULTILINE)
test_str = ("[color=red;font-size:100pt;]DEFACED[/color]\n"
"[color=#FF0000]DEFACED?[/color]")
subst = "<span style=\"font-color:$1>$2</span>"
result = regex.sub(subst, test_str)
if result:
print(result)