import Foundation
let pattern = ##"\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
[color=red;font-size:100pt;]DEFACED[/color]
[color=#FF0000]DEFACED?[/color]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span style="font-color:$1>$2</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)