#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "AA\b"
Local $sString = "AAAA AAAAAAAA AAA AAAAA"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)