$re = '/AA\b/';
$str = 'AAAA AAAAAAAA AAA AAAAA';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;