const regex = /AA\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('AA\\b', 'g')
const str = `AAAA AAAAAAAA AAA AAAAA`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);