using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AA\b";
string substitution = @"";
string input = @"AAAA AAAAAAAA AAA AAAAA";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}