import Foundation
let pattern = #"AA\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"AAAA AAAAAAAA AAA AAAAA"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)