#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "'?(\w+(?:\s+\w+)*)?'?\s*<?(\S+@[\w.-]+\.[a-zA-Z]{2,4}\b)"
Local $sString = "Name Surname email@domain.com" & @CRLF & _
"" & @CRLF & _
"'Name Surname' <email@domain.com>" & @CRLF & _
"" & @CRLF & _
"'Name Surname' email@domain.com" & @CRLF & _
"" & @CRLF & _
"Name Surname <email@domain.com>" & @CRLF & _
"" & @CRLF & _
"email@domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")