import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'?(\\w+(?:\\s+\\w+)*)?'?\\s*<?(\\S+@[\\w.-]+\\.[a-zA-Z]{2,4}\\b)";
final String string = "Name Surname email@domain.com\n\n"
+ "'Name Surname' <email@domain.com>\n\n"
+ "'Name Surname' email@domain.com\n\n"
+ "Name Surname <email@domain.com>\n\n"
+ "email@domain.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}