$re = '/\'?(\w+(?:\s+\w+)*)?\'?\s*<?(\S+@[\w.-]+\.[a-zA-Z]{2,4}\b)/';
$str = 'Name Surname email@domain.com
\'Name Surname\' <email@domain.com>
\'Name Surname\' email@domain.com
Name Surname <email@domain.com>
email@domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);