using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'?(\w+(?:\s+\w+)*)?'?\s*<?(\S+@[\w.-]+\.[a-zA-Z]{2,4}\b)";
string input = @"Name Surname email@domain.com
'Name Surname' <email@domain.com>
'Name Surname' email@domain.com
Name Surname <email@domain.com>
email@domain.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}