#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[AQ]:.*(?:\n+(?![AQ]:).+)*"
Local $sString = "Q: This is a question. " & @CRLF & _
"Q: This is a 2nd question " & @CRLF & _
"on two lines." & @CRLF & _
"" & @CRLF & _
"A: This is an answer. " & @CRLF & _
"A: This is a 2nd answer " & @CRLF & _
"on two lines." & @CRLF & _
"Q: Here's another question. " & @CRLF & _
"A: And another answer." & @CRLF & _
"" & @CRLF & _
"Testing." & @CRLF & _
"123."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")