# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[AQ]:.*(?:\n+(?![AQ]:).+)*"
test_str = ("Q: This is a question. \n"
"Q: This is a 2nd question \n"
"on two lines.\n\n"
"A: This is an answer. \n"
"A: This is a 2nd answer \n"
"on two lines.\n"
"Q: Here's another question. \n"
"A: And another answer.\n\n"
"Testing.\n"
"123.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.