re = /^[AQ]:.*(?:\n+(?![AQ]:).+)*/m
str = 'Q: This is a question.
Q: This is a 2nd question
on two lines.
A: This is an answer.
A: This is a 2nd answer
on two lines.
Q: Here\'s another question.
A: And another answer.
Testing.
123.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end