import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[AQ]:.*(?:\\n+(?![AQ]:).+)*";
final String string = "Q: This is a question. \n"
+ "Q: This is a 2nd question \n"
+ "on two lines.\n\n"
+ "A: This is an answer. \n"
+ "A: This is a 2nd answer \n"
+ "on two lines.\n"
+ "Q: Here's another question. \n"
+ "A: And another answer.\n\n"
+ "Testing.\n"
+ "123.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}