#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(RETCODE = ) (\[0-9]+)"
Local $sString = "RETCODE = 7200 Duplicate records" & @CRLF & _
"" & @CRLF & _
"There is together 1 report" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")