$re = '/(RETCODE = ) (\[0-9]+)/';
$str = 'RETCODE = 7200 Duplicate records
There is together 1 report
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);