const regex = /(RETCODE = ) (\[0-9]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(RETCODE = ) (\\[0-9]+)', '')
const str = `RETCODE = 7200 Duplicate records
There is together 1 report
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}