re = /(RETCODE = ) (\[0-9]+)/
str = 'RETCODE = 7200 Duplicate records
There is together 1 report
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end