package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(RETCODE = ) (\[0-9]+)`)
var str = `RETCODE = 7200 Duplicate records
There is together 1 report
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}