# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<blockquote>(?:(?!<\/?blockquote).)*?)<p>(.*?)<\/p>((?:(?!<\/?blockquote).)*<\/blockquote>)/\1<div>\2<\/div>\3/sg;t' <<< "<blockquote>
<div>paragraph 1</div>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<div>paragraph 2</div>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>"