$re = '@(<blockquote>(?:(?!</?blockquote).)*?)<p>(.*?)</p>((?:(?!</?blockquote).)*</blockquote>)@s';
$str = '<blockquote>
<div>paragraph 1</div>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<div>paragraph 2</div>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>';
$subst = "\1<div>\2</div>\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;