using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<blockquote>(?:(?!</?blockquote).)*?)<p>(.*?)</p>((?:(?!</?blockquote).)*</blockquote>)";
string substitution = @"\1<div>\2</div>\3";
string input = @"<blockquote>
<div>paragraph 1</div>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<div>paragraph 2</div>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}