const regex = new RegExp('(<blockquote>(?:(?!</?blockquote).)*?)<p>(.*?)</p>((?:(?!</?blockquote).)*</blockquote>)', 'sg')
const str = `<blockquote>
<div>paragraph 1</div>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<div>paragraph 2</div>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>`;
const subst = `\1<div>\2</div>\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);