re = /(<blockquote>(?:(?!<\/?blockquote).)*?)<p>(.*?)<\/p>((?:(?!<\/?blockquote).)*<\/blockquote>)/
str = '<blockquote>
<div>paragraph 1</div>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<div>paragraph 2</div>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>'
subst = '\\1<div>\\2</div>\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result