use strict;
my $str = 'Icon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.png';
my $regex = qr/(Icon=).*\/(.*)(.png)/xp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";