import Foundation
let pattern = #"(Icon=).*\/(.*)(.png)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"Icon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.png"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)